如果宅|网络工程师培训

华为路由器配置 GRE OVER IPSEC 跨公网运行OSPF动态路由

如果宅|网络工程师培训 http://www.ifzhai.com 2019-01-22 09:58 出处:网络 编辑:PinG
GRE协议可以承载动态路由,而不具备加密特性,而IPsec可以加密却不可承载动态路由,所以使用GRE+IPSEC完成OSPF在公网上的运行。
(如果本文中的图片看不清,可按住键盘Ctrl键+鼠标滚轮上键)


华为路由器配置 GRE OVER IPSEC 跨公网运行OSPF动态路由

GRE协议可以承载动态路由,而不具备加密特性,而IPsec可以加密却不可承载动态路由,所以使用GRE+IPSEC完成OSPF在公网上的运行。

拓扑图注释:

AR1,为公司A;L0模拟内网IP,tunnel0自行配置的隧道IP,50.1.1.2为A公司公网IP

AR4,为公司B;

AR2/AR3模拟运行商网络。


配置部分

--------------------------------------------------------------------------------------------

AR2/AR3配置接口IP,并指定到50.1.1.0/24、60.1.1.0/24的路由。

以AR2配置为例。

#

interface GigabitEthernet0/0/0

 ip address 200.1.1.1 255.255.255.0 

#

interface GigabitEthernet0/0/1

 ip address 50.1.1.1 255.255.255.0 

#

ip route-static 60.1.1.0 255.255.255.0 200.1.1.2

--------------------------------------------------------------------------------------------

AR1配置


#创建IKE

ike proposal 1

 encryption-algorithm 3des-cbc

 authentication-algorithm md5

#创建IKE对等体

ike peer r3 v2

 pre-shared-key simple test

 ike-proposal 1

#创建IPSEC

ipsec proposal 1

 esp encryption-algorithm 3des

#IPSEC配置文件

ipsec profile gre

 ike-peer r3

 proposal 1

#

interface GigabitEthernet0/0/1

 ip address 50.1.1.2 255.255.255.0 

#

interface LoopBack0

 ip address 192.168.1.1 255.255.255.0 

#GRE Tunnel配置部分

interface Tunnel0/0/0

 ip address 192.168.3.1 255.255.255.0 

 tunnel-protocol gre

 source 50.1.1.2

 destination 60.1.1.2

 ipsec profile gre

#OSPF配置部分

ospf 1 

 area 0.0.0.0 

  network 192.168.1.0 0.0.0.255 

  network 192.168.3.0 0.0.0.255 

#

ip route-static 0.0.0.0 0.0.0.0 50.1.1.1


--------------------------------------------------------------------------------------------


AR4的配置与AR1基本相似,不做过多注释。

#

ipsec proposal 1

 esp encryption-algorithm 3des

#

ike proposal 1

 encryption-algorithm 3des-cbc

 authentication-algorithm md5

#

ike peer r3 v2

 pre-shared-key simple test

 ike-proposal 1

#

ipsec profile gre

 ike-peer r3

 proposal 1

#

interface GigabitEthernet0/0/1

 ip address 60.1.1.2 255.255.255.0 

#

interface LoopBack0

 ip address 192.168.2.1 255.255.255.0 

#

interface Tunnel0/0/0

 ip address 192.168.3.2 255.255.255.0 

 tunnel-protocol gre

 source 60.1.1.2

 destination 50.1.1.2

 ipsec profile gre

#

ospf 1 

 area 0.0.0.0 

  network 192.168.2.0 0.0.0.255 

  network 192.168.3.0 0.0.0.255 

#

ip route-static 0.0.0.0 0.0.0.0 60.1.1.1

#





(转载请注明出处:如果宅www.ifzhai.com)

0

上一篇:

没有了 :下一篇